Page 1 of 1

One of more databases could not be opened

Posted: November 6th, 2020, 16:43
by thebourboncowboy
I'm getting this error every time I try to start Resonic:
Resonic Player could not start

One or more databases could not be opened or created. Disk full, protected, or inaccessible?
This error occurs on laptops that are connected to a windows server and use remote offline when the laptop is outside the office windows syncs the profile to an encrypted area on the local hard drive...and resyncs with the server when they are back in the building. Resonic works perfectly while inside the building, but we get this error when away from the office.

I've tried to alter the settings in the ResonicBoot.ini file so that it looks to a folder on C:\ for the databases, but Resonic doesn't seem to be reading that file before it loads. I get the exact same error when I try to launch resonic, regardless of what I write in the resonicboot.ini

Posted: November 6th, 2020, 17:16
by Tom
This seems to be a very special use case that we haven't covered yet.

Please download and run - then copy/paste the results into either an email or a private message here so we can have a look at what might be going wrong here.

Also, check your PMs, I sent you something else.

Posted: November 6th, 2020, 19:01
by Tom
I'm going to reply publicly to your PM here (sensitive information removed):
thebourboncowboy wrote:
November 6th, 2020, 18:40
This is the text output from the paths test:
CSIDL_LOCAL_APPDATA resolved to <C:\Users\xxxxx\AppData\Local>
AppData base path <C:\Users\xxxxx\AppData\Local\Liqube\Resonic\Player Beta\>
Could not resolve CSIDL_MYDOCUMENTS, error code 80070035
Base path initialization failed

In an attempt to get the ResonicBoot.ini to work, I have these two settings:
According to this error code your Documents folder is in a network location, like you described, but Resonic fails to access/read it.

I'm assuming you're on Player 0.9.3? I checked the code and with an error like this it wouldn't even be able to reach the point where it reads ResonicBoot.ini, so editing it will be in vain. There is nothing I can do about this when it comes to 0.9.3.

Since we've reworked the paths initialization and handling for Pro 0.9.4 this might have already been fixed. I suggest you email/PM/DM me your full name + email and I'll send you a trial so you can test the latest Alpha and see if that has helped. We figure out a working solution from there.

You mentioned that you're not using the Pro. Please keep in mind that using the free Player in a business setting doesn't really help us further the project. Since this is an independent project we're reliant on users to purchase Pro licenses to finance development. Sadly, because this happened quite a bit in the past we have no plans on bringing bigger updates to the free Player for the time being.

Posted: November 6th, 2020, 19:34
by thebourboncowboy
Thanks Tom! We're a non-profit organization and have assumed we were correctly using Resonic player under the correct license agreement. If we aren't we will rectify that immediately.

Posted: November 7th, 2020, 03:03
by Tom
All good, understood :)

Just thought I'd mention it for others to read as well. Sadly in the past we've learned that several commercial entities, not even small ones, are not really helping us out here.

That much being said we're always happy about donations.

Re: One of more databases could not be opened

Posted: April 7th, 2021, 14:24
by motownmac
My problem is very similar. If I were able to set the location for the database files in the ResonicBoot.ini file it would be solved, but I don't have time to test the alpha product. If someone successfully tests this capability I would appreciate hearing about it. I'm running the free version of 0.9.3 and can't upgrade to Pro until this issue is resolved.

Posted: April 7th, 2021, 18:20
by Tom
Frankly starting the Alpha (0.9.4) to see whether this works takes very little time and no one can do this for you to see whether it works as expected on your system. Keep in mind though the path override has been removed from the ResonicBoot.ini in 0.9.4. We'll see what to do with it in future updates, maybe bring it back for the next update if there really is a need for it?

Free and Pro are both identical in path handling, so 0.9.3 Pro won't behave any different than 0.9.3 Free.