Prepare, but don't play - Keyboard workflow

Comments, ideas, suggestions, criticism. Your thoughts.
Post Reply
User avatar
A1RO
Starting to like this
Posts: 17
Joined: January 20th, 2018, 01:45
First Name: Antoine
Artist Handle: Aone-Records
Your primary DAWs: Reaper
Location: Québec, Canada
Contact:

Prepare, but don't play - Keyboard workflow

Hi again,

I like to use the somewhat hidden Prepare, but don't play (cue ready) playback mode.
IMHO, it has great potential but I find it's missing the point about keyboard shortcuts.

While I appreciate the quickness of using the Up/Down arrows to audition files, sometimes I want to choose a folder, skip a few tracks and listen to, say, the 7th file only. When doing so, I'm not interested in hearing the first bits of every file along the way. Right now, I think there's no option to do this kind of "standard" browsing through files with a keyboard-only workflow. That's where the Prepare, but don't play (cue ready) mode comes along.

To sum up what I understand of the actual behavior:
Left-Click on file and Ctrl+Up/Down (when file list focused) work as intended since they print waveform then hit pause.
On the other hand, Up/Down (when file list focused) and Ctrl+Up/Down (when browser focused) do not work as intended since they play files right away.

So, to improve keyboard productivity, could the last two shortcuts be modified?

Also, as a bonus, I would add Prepare, but don't play (cue ready) setting (along with the standard Play immediately setting) to Play/Pause buttons Right-Click menu for a quick toggle between the two.

By the way, congrats on the 0.9.1 release. I believe it brings a good balance of feature and reliability.
Keep it up!

Tom
Liqube Audio
Liqube Audio
Posts: 981
Joined: December 12th, 2012, 19:12
First Name: Tom
Artist Handle: Liqube
Your primary DAWs: Live, Cubase
Location: Over there
Contact:

Re: Prepare, but don't play - Keyboard workflow

This is indeed an issue that seems to be new in 0.9: a few file list playback mechanics have changed, so it's clear why this is happening. Playback should never start the first time around. I've put this on the 0.9.2 todo.

I like the bonus idea!
Join our Slack community for chat, testing, and new builds; or our Resonic Users FB group.

A user interface is like a joke: if you have to explain it, it's not that good.

User avatar
A1RO
Starting to like this
Posts: 17
Joined: January 20th, 2018, 01:45
First Name: Antoine
Artist Handle: Aone-Records
Your primary DAWs: Reaper
Location: Québec, Canada
Contact:

Re: Prepare, but don't play - Keyboard workflow

With Prepare, but don't play (cue ready) set, and with Stop after current file disabled, playback will pause at the end of file instead of playing next track (no matter what) if playback was initially started by any seek command.

To reproduce, set Prepare, but don't play (cue ready), then Left-Click on any file to engage preloading, and start playback with a seek command (i.e. almost anything except Space or Enter). You can let it finish or keep on seeking, and the file will always pause at the end.

Examples of guilty seek commands: Left-Click on waveform, Ctrl+Wheel on waveform, Left/Right arrows, Ctrl+Left/Right arrows, Num 1, Num 2, Num 3, and so on.

Seems like a bug to me. Can you confirm?

Martin
Liqube Audio
Liqube Audio
Posts: 97
Joined: September 13th, 2014, 19:30
First Name: Martin
Location: On a tree, throwing bananas

Re: Prepare, but don't play - Keyboard workflow

Yep, that's a bug.

Post Reply