Alpha 0.6b Build 12261

Discuss Beta and Unstable builds here
Forum rules
Grab the latest unofficial Resonic builds at stuff.liqube.com and discuss them here.
Join our Discord at discord.liqube.com for updates, chats and talks.
Locked
Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Alpha 0.6b Build 12261

Welcome to the very first batch of private Beta builds of Resonic Player.

These builds are unfinished products. Each new build focuses on certain things that need to be tested.
The goal is to get the Beta functionally close to the final Alpha release, which is 999.

While the interface seems pretty much the same every aspect of the application has been overhauled. Please note that we always start off with reduced versions, features are added step by step.

Please post all findings and issues (bugs, missing features, missing functionality, weird behavior) even though many of them seem obvious and may already be known. Test CPU usage on your system, overall performance, memory use, and if there is anything you don't understand about anything new, or if there are things that don't make sense to you, please ask.

Builds show nag messages after a few weeks, after a few months they become obsolete.

Always get the newest file attached to this post.
I sometimes keep a few older builds attached so you can go back and compare if something changes for the better, or worse.
The files are usually named like this: resonic-BUILDTYPE-DATE-BUILD.zip

Extract to a temporary writable location, make sure to read the included instructions.txt and see whatsnew.txt for a list of preliminary changes (not all of them are in there).

Happy testing :)
Attachments
resonic-test-150321-12261b.zip
(9 MiB) Downloaded 340 times
resonic-test-150309-12180b.zip
(9.02 MiB) Downloaded 376 times
resonic-test-150219-12102b.zip
(8.96 MiB) Downloaded 358 times
resonic-test-150214-12034b.zip
(9.06 MiB) Downloaded 365 times
resonic-test-150212-11955b.zip
(9.07 MiB) Downloaded 386 times
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

User avatar
ExtremRaym
Beta Tester
Posts: 50
Joined: April 12th, 2014, 18:35
Artist Handle: X-Raym
Primary DAW: Reaper
Location: France
Contact:

Re: 10829 - Beta Test

Let's test !

User avatar
wshaper
Beta Tester
Posts: 94
Joined: September 23rd, 2013, 21:06
Primary DAW: Reaper, Live

Re: 10829 - Beta Test

Great, thank you !
Can we choose the soundca

User avatar
ExtremRaym
Beta Tester
Posts: 50
Joined: April 12th, 2014, 18:35
Artist Handle: X-Raym
Primary DAW: Reaper
Location: France
Contact:

Re: 10829 - Beta Test

First impressions :
Nice, clean.
Waveform is unfortunately missing for the moment :D

Some points :
  • We need a temporary playlist (with add to current playlist and add after the file beig played) functions,etc...
  • With other visualization than waveform, we need a small indicator to indicate where we are in the song (a full width 10 px height bar with the playback position would be perfect). Otherwise, we can click where we want in the sound if visualization is not waveform..
  • It seems to have tabs but we can't open folders in new tabs
  • Improve Listening Stereo button has no visual cue when on/off (does it works ?)
  • Same thing for the button left to the headphones, but more, it has no tooltip when the mouse is over it.
  • bits column does't display anything but "-"
  • Musical Spectrum is blinking
Windows 7 64 bits.

Otherwise, it seems to be ok. But I don't test everything yet ^^
Nice job !

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

ExtremRaym wrote:We need a temporary playlist (with add to current playlist and add after the file beig played) functions,etc...
This comes in Beta 2. For now, please concentrate on the things that are currently there.
Improve Listening Stereo button has no visual cue when on/off (does it works ?).
No function just yet, but soon.
bits column does't display anything but "-"
Depends on file format/file. MP3/MP4, etc. don't have bit depths.
Musical Spectrum is blinking
For certain sampling rates it seems to blink, yes. Noted.
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

wshaper wrote:Can we choose the soundca
Not yet.
Please just test what's there for now.
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

User avatar
wshaper
Beta Tester
Posts: 94
Joined: September 23rd, 2013, 21:06
Primary DAW: Reaper, Live

Re: 10829 - Beta Test

Great, thank you !
Can we choose the soundcard device (or select an Asio driver) yet ?

Andreasvb
Moderator
Posts: 116
Joined: January 29th, 2013, 06:35
Location: Sweden

Re: 10829 - Beta Test

Will test in a bit, on my way home.
:ugeek: Windows 10 Pro x64 / Resonic Pro - Beta 0.8.9

User avatar
ExtremRaym
Beta Tester
Posts: 50
Joined: April 12th, 2014, 18:35
Artist Handle: X-Raym
Primary DAW: Reaper
Location: France
Contact:

Re: 10829 - Beta Test

On windows 7 :
Roots of Libraries appears empty.
The same folder appear just fine when access to more regular browsing (C:/...)

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

ExtremRaym wrote:On windows 7 : Roots of Libraries appears empty.
Win7x64 here, nothing like that. Explain more pls, screenshots help (attach here)
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

mrfox
Beta Tester
Posts: 42
Joined: April 2nd, 2013, 13:54

Re: 10829 - Beta Test

Great to hear! I'll start testing it tomorrow and I'll report back.

User avatar
ExtremRaym
Beta Tester
Posts: 50
Joined: April 12th, 2014, 18:35
Artist Handle: X-Raym
Primary DAW: Reaper
Location: France
Contact:

Re: 10829 - Beta Test

As you can see on this screenshot, I'm on the Musiques library, but no folders and no sound appear in the Resonic Browser.

User avatar
ExtremRaym
Beta Tester
Posts: 50
Joined: April 12th, 2014, 18:35
Artist Handle: X-Raym
Primary DAW: Reaper
Location: France
Contact:

Re: 10829 - Beta Test

Still on Windows 7 64 bit :
On the task bar, the progression is shown as green when a file is playing.
This works only is the Resonic Window is in not focus, and disapear when it is.
Would be better to have it displayed all the time.
(screenshot : Resonic not in focus

Martin
I know my Resonics, all of them!
Posts: 91
Joined: September 13th, 2014, 19:30
First Name: Martin
Location: On a tree, throwing bananas

Re: 10829 - Beta Test

ExtremRaym wrote:On windows 7 :
Roots of Libraries appears empty.
The same folder appear just fine when access to more regular browsing (C:/...)
Yes, that's a known issue (#137 @ Tom).

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

Martin wrote:
ExtremRaym wrote:On windows 7 :
Roots of Libraries appears empty.
The same folder appear just fine when access to more regular browsing (C:/...)
Yes, that's a known issue (#137 @ Tom).
Right. Was distracted by "empty".
ExtremRaym wrote:Still on Windows 7 64 bit :
On the task bar, the progression is shown as green when a file is playing.
This works only is the Resonic Window is in not focus, and disapear when it is.
Would be better to have it displayed all the time.
(screenshot : Resonic not in focus
That'll be an option.
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

pumafred
Really likes it here
Posts: 38
Joined: May 1st, 2013, 22:08
Location: Argentina

Re: 10829 - Beta Test

Great, thanks! I will test, though I am not an intensive user.

Andreasvb
Moderator
Posts: 116
Joined: January 29th, 2013, 06:35
Location: Sweden

Re: 10829 - Beta Test

Thanks for the new beta. 8-)

My current observations.

Process Explorer
32 MB RAM
Stopped: 0-1 % CPU
Playing: 0-4 % CPU (minimized: 0.8, spectrum: 2.0, analyzer: 4.0 outline 3.0 solid, off: 1.7)
Paused: 2-3 % CPU (seems it still process visualizer but it's frozen only visually)
+ New column: 'Extension', just the file's extension.
When the 'Extension' column is visible file extensions in the 'File name' column are hidden.
If it's Ext. it doesn't hide the extension from File name column.
+ New option allows you to toggle filename in main window title.
Can hide but not show it again without switching track.
# Renamed 'Avoid horizontal scrollbar' option to 'Auto-fit to width' (columns)
The status bar message is the old name.
Also, the vertical scroll bar is visible as the list is overflowing by only some pixel (edit: happens only when horizontal scroll bar is visible).
  • ? Can't disable Show level meter.
    ? Disabling Enable global hotkeys has no effect, also gets unchecked after reopening Preferences.
    ? If right clicking on volume then dismiss or any other option and then moving mouse over it will behave as you hold down left click, need to click again inside it to release.
    * Should be able to make Length column narrower.
    + Would be nice to have zZz at bottom right corner open the Sleep Timer menu.
    + When adding back the seekbar in visualizer, make Musical Spectrum show progress by highlight bar orange (just like when holding mouse over).
:ugeek: Windows 10 Pro x64 / Resonic Pro - Beta 0.8.9

LopDog
Likes it here
Posts: 26
Joined: April 8th, 2013, 20:09

Re: 10829 - Beta Test

Hi There
my report :

-The startup seem slower than previous build.

-The cpu usage is about 2% (but hit sometimes 0 or 1%) of my cpu, with 25 000ko of memory usage while previous build is about always 0% and 21 000ko of memory usage.

-I notice a weird behavior on the buffer audio i guess.
Because one time i played a .flac,and at the ending , the player stopped with the statue "error", i couldn't found the exact bug sorry, but after this, The player did like a stutter effect on 2 others mp3 songs.

-The button on the left of the headphones's button, the description is missing. And these two buttons don't work for the moment.
I guess that you know it, but i don't found any informations about this on the "what's new file"

-The button "Zzz" at the corner right seem broken too. The description is missing, even if we guess that the sleep mode



off topic :accordance with your improvements, the new logarithmic spectrum seem more precise and "musical" than previous build, and this is awesome !

Windows 7 / 64 bits / cpu intel i5 4670


hope this report help you

mrfox
Beta Tester
Posts: 42
Joined: April 2nd, 2013, 13:54

Re: 10829 - Beta Test

Startup is extremely fast, the browser is a but a bit jumpy for network files. The dim button is awesome, great idea!

The only problem I found so far is that I can't drag&drop multiple network files from windows explorer if the network location is not mapped as a drive. It works fine if the network location is mapped.

Cpu usage is between 1-5% on a core i3 system, 0-3% on a amd fx8350 system (both Windows 8.1).

That's all for now, I'll keep using it from now on, and report back if anything comes out.

Alt
Beta Tester
Posts: 41
Joined: October 4th, 2014, 13:10

Re: 10829 - Beta Test

* As other testers stated, comparing to 'Final Alpha': loading is slower; CPU usage by interface (I guess because when minimized it's fine) is greater (with both played music (2-5, rarely 6%) and in idle (1-2%) while with FA it was nearly 0% most of the time); navigation feels smoother now;
* MP4-AAC format in all containers (MP4, M4A, AAC) doesn't play (shows error);
* Musepack format doesn't show any metadata;
* "Resume playback at startup" doesn't work, track always starts to play from beginning;
* "Refresh" command (F5) doesn't work;
* Cyrillic characters in ISO-8859-1 (Latin-1; Windows-28591) codepage still doesn't show correctly;
* Resonic still doesn't set lower track's input SampleRate for DirectSound output. However player still always sets 44.1 KHz on startup so lower SR (like 32 KHz) can't be set at all. Not sure if the last thing is bad since some drivers (Xonar ASIO for example) doesn't support 32 KHz. But still IMO player shouldn't set 44.1 SR when nothing asking to do so;
* Bit-rate for APE format doesn't always show correctly (e.g. "-298" "-414", "-814");
* There should also be warning message for 'support the project' button;
(?) No "play next/prev" track global hotkey?
(?) What \addons\bass.dll serves for? It's older then file in root folder and looks like it's currently not used.
Last edited by Alt on November 28th, 2014, 16:14, edited 1 time in total.

Jan
Beta Tester
Posts: 29
Joined: April 8th, 2014, 00:41
Resonic: Player

Re: 10829 - Beta Test

Operating System: Windows 10x64 (Build 9879)

Hey Tom,

I am so happy you made it so far. The buid looks great and I'll dive into bugtesting now:

Waveform:
- The default waveform is missing (known bug)
- You can't waveform-navigate through a songs timeline at the moment (known bug)

- Analyze style "Outline" doesn't change "Musical spectrum" - most likely no bug, but feels a tad inconsistent.

Command Cards
- Playback commands working fine checked
- Love the dimmer button ("Temporarily reduce volume")
- "Improve headphone listening experience" and the icon to its left don't work right now

Sleep Timer:
- Use remaining playback tme
Doesn't adjust to the tracks current time / won't always trigger
- Custom "1 minute" checked
Music starts playing as soon as pc awakes

Set to "Exit Resonic"
- Custom "1 minute" checked

Taskbar Icon
- Icon not in focus
The icon blinks sometimes

Interface Options (show/hide)
- Mostly all of the work fine, just "Show level meter" won't make any difference/react

Other Functions
- Global hotkeys can't be set yet

Martin
I know my Resonics, all of them!
Posts: 91
Joined: September 13th, 2014, 19:30
First Name: Martin
Location: On a tree, throwing bananas

Re: 10829 - Beta Test

Alt wrote:CPU usage by interface (I guess because when minimized it's fine) is greater (with both played music (2-5, rarely 6%) and in idle (1-2%)
The idle CPU usage may be caused by the currently defunct waveform view. Could you check if it goes down to 0% if you switch to one of the analyzers?

Alt
Beta Tester
Posts: 41
Joined: October 4th, 2014, 13:10

Re: 10829 - Beta Test

Jan wrote: - Global hotkeys can't be set yet
Actually they work all the time and can't be disabled (unless you 'clean' previously assigned hotkeys), that's just broken 'checkbox' misinform us :)
Martin wrote:
Alt wrote:CPU usage by interface (I guess because when minimized it's fine) is greater (with both played music (2-5, rarely 6%) and in idle (1-2%)
The idle CPU usage may be caused by the currently defunct waveform view. Could you check if it goes down to 0% if you switch to one of the analyzers?
Yes, analyzers and musical spectrum seem fine.

User avatar
BTGbullseye
Beta Tester
Posts: 137
Joined: March 22nd, 2013, 10:19
Location: a particular place or position.
Contact:

Re: 10829 - Beta Test

Temporary volume reduction works nice.
Musical spectrum visualization looks cool.
Music plays back very smooth and clean/clear.
Startup is actually faster by 2 seconds over previous versions of Resonic.
Sits around 3% CPU usage with a high-bitrate FLAC at maximum compression.
Hitting 'next track' button at the end of the list does nothing. (would be nice if it could loop to the first track when you hit the button manually)
Analyzer style works nice, and looks nice.
The 'hide mouse inside visualization area' option doesn't work.
Doesn't show played area, and the option to not shade it doesn't function.
Resume playback starts the file from the beginning instead of where it left off.
The stop button has a little triangle in the lower right corner, it does nothing now, is it for stop options?
After pressing the stop button, pressing the play button does nothing.

[EDIT] I have no idea what I did, but the loop isn't on, and it's looping the same track over and over... Restarting didn't fix it.
[EDIT2] I fixed the problem by pressing the next track button twice. Still no idea what caused it.
Last edited by BTGbullseye on November 29th, 2014, 08:35, edited 1 time in total.
I don't suffer from insanity... I'm still insane though.

sergeyapanin
Getting the hang of it
Posts: 8
Joined: January 12th, 2014, 21:17

Re: 10829 - Beta Test

- Volume Slider: rightclick on slider, select any volume from menu (leftclick) and move mouse on that slislider - volume is "stacked" till you click on slider again
- No progress play in windows bar icon (Windows 7x64, 4gb RAM)
- Some micropauses in playing, when i surfing in the internet, for example
- No some popup infos:
Attachments
POPUP.jpg
POPUP.jpg (42.5 KiB) Viewed 29501 times

Blackout
Beta Tester
Posts: 120
Joined: September 6th, 2013, 16:05

Re: 10829 - Beta Test

hi Tom , ive had a good play. Ive seen the same problems and I don't want to double-up on whats already been found here.

Well I know this is not exactly a bug but the "Explorer Menu" when you right-click on a file is fantastic and a welcome addition! however it keeps resetting every time you use it, you have to re-select "Explorer Menu" and its really frustrating. Can you possibly make this a setting instead under "File" that sets it globally, and saves the setting for the next Resonic session?

as you may have gathered from my posts I want to use Resonic as a sample manager, if you make the right-click able to be a "Explorer Menu" option by default in a setting it means I can then use the "Move To" option for a sample that is standard in Windows Explorer and move the sample to a new folder. This is a biggie for me. Then I could sort samples a lot easier.

either this or implement a "Move to" in the resonic right-click options...but I feel it will be a LOTTT easier for you to do my first suggestion and not have to re-invent the wheel..

Cheers!
Blackout

Martin
I know my Resonics, all of them!
Posts: 91
Joined: September 13th, 2014, 19:30
First Name: Martin
Location: On a tree, throwing bananas

Re: 10829 - Beta Test

Blackout wrote:however it keeps resetting every time you use it, you have to re-select "Explorer Menu" and its really frustrating.
You can hold down the shift key when right-clicking files to go directly to the explorer menu

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

Alt wrote:MP4-AAC format in all containers (MP4, M4A, AAC) doesn't play (shows error)
Some details on this please?
Musepack format doesn't show any metadata;
Which file extensions, have demo files?
Also @BTGbullseye:
I'd need some demo files for that. Can you please upload them to ftp://resonic.at (user: f009e033, pass: incoming)
Bit-rate for APE format doesn't always show correctly (e.g. "-298" "-414", "-814")
Same here, can you provide some demo files?
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

BTGbullseye wrote:The stop button has a little triangle in the lower right corner, it does nothing now, is it for stop options?
Yes, to be an options menu.
After pressing the stop button, pressing the play button does nothing.
You mean, it's not green, but still plays?
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

Jan wrote:Operating System: Windows 10x64 (Build 9879)
Any issues/visual problems on Windows 10 so far? Can you post a screenshot of the main window, just for reference.
remaining playback time. Doesn't adjust to the tracks current time / won't always trigger
Won't always trigger?
Taskbar Icon- Icon not in focus The icon blinks sometimes
Can you explain in detail?
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

To any of you who experience slower startup than in the Alpha:
Did you actually compare the startup time to the Alpha using the same startup folder?
Do you have special shell extensions installed?
Does your Explorer lag a bit in certain locations too?

Startup should be much faster in general now. Even plugins are only loaded when needed.
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Blackout
Beta Tester
Posts: 120
Joined: September 6th, 2013, 16:05

Re: 10829 - Beta Test

startup was surprisingly faster for me now (Win7 x64) than the 999 Alpha

Jan
Beta Tester
Posts: 29
Joined: April 8th, 2014, 00:41
Resonic: Player

Re: 10829 - Beta Test

Jan wrote:Operating System: Windows 10x64 (Build 9879)
Tom wrote:Any issues/visual problems on Windows 10 so far? Can you post a screenshot of the main window, just for reference.
Hard to say, since I have a lot of trouble with my current system and I'm planning to make a clean install somewhat soon. I will keep an eye on it to make sure my feedback is valid.
Jan wrote:remaining playback time. Doesn't adjust to the tracks current time / won't always trigger
Tom wrote:Won't always trigger?
"Remaining playing time must be at least one minute long" Okay this answers my "wont' always trigger" problem.
Jan wrote:Taskbar Icon- Icon not in focus The icon blinks sometimes
Tom wrote:Can you explain in detail?
http://youtu.be/kG0jeBnXKmo (might be Windows bugging, but I haven't noticed this problem with any other app so far).

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

Jan wrote:The icon blinks sometimes. http://youtu.be/kG0jeBnXKmo (might be Windows bugging, but I haven't noticed this problem with any other app so far).
When exactly does this happen? Always, or just in certain situations? Does this happen with other applications that update the taskbar progress bar? Does that happen with the Alpha 999's icon too?
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Andreasvb
Moderator
Posts: 116
Joined: January 29th, 2013, 06:35
Location: Sweden

Re: 10829 - Beta Test

Jan wrote:
Jan wrote: http://youtu.be/kG0jeBnXKmo (might be Windows bugging, but I haven't noticed this problem with any other app so far).
There seems to be a nasty bug in the new Windows 10 build 9879, making Explorer create a lot of GDI objects when taskbar objects update.
Tom is aware of it, but not sure if he can do anything except disable the animation.

I've tried it in VirtualBox and Resonic adds 12 objects every second, when Explorer reaches around 9 000 everything stops working, can't open Explorer windows, fonts going haywire, etc.
9879: GDI Objects resource leak in explorer.exe (directly affects Taskbar)
https://social.technet.microsoft.com/Fo ... 014General
:ugeek: Windows 10 Pro x64 / Resonic Pro - Beta 0.8.9

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10897 - Beta Test

resonic-test-141203-11006b

Here's a list of changes/fixes, most of them being your reports:
Attachments
resonic-test-141130-10897b changes.png
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

User avatar
wshaper
Beta Tester
Posts: 94
Joined: September 23rd, 2013, 21:06
Primary DAW: Reaper, Live

Re: 10897 - Beta Test

Hi
A bit late to the party, sorry, and congratulations for releasing a new beta build ! :D
This portable version works smoothly so far (Win7, 64bit).
I will report any bug, issue or weird behaviour.
Cheers !

User avatar
MaxLapierre
Beta Tester
Posts: 53
Joined: January 30th, 2013, 00:27
Location: Canada
Contact:

Re: 10897 - Beta Test

I am testing the new beta and I will report any bug.

Thanks Tom :D
www.MaxLapierre.com

User avatar
BTGbullseye
Beta Tester
Posts: 137
Joined: March 22nd, 2013, 10:19
Location: a particular place or position.
Contact:

Re: 10829 - Beta Test

Tom wrote:Also @BTGbullseye:
I'd need some demo files for that. Can you please upload them to ftp://resonic.at (user: f009e033, pass: incoming)
Wait, for which issue?
Tom wrote:
After pressing the stop button, pressing the play button does nothing.
You mean, it's not green, but still plays?
No, it doesn't play. It does nothing at all.
Tom wrote:A new build is available, attached to the original post: resonic-test-141130-10897b.zip
Giving it a try now. :)

[EDIT] You fixed the play button not functioning after pressing the stop button as well in this Beta! YAY! lol
I found no new issues with it yet.
I don't suffer from insanity... I'm still insane though.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

BTGbullseye wrote:Wait, for which issue?
Nevermind, confused things.
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Alt
Beta Tester
Posts: 41
Joined: October 4th, 2014, 13:10

Re: 10897 - Beta Test

Tom wrote:
Alt wrote:MP4-AAC format in all containers (MP4, M4A, AAC) doesn't play (shows error)
Some details on this please?
Player just shows error "unsupported format or corrupted file". Uploaded files in "MP4-AAC demo.zip"
Tom wrote:
Musepack format doesn't show any metadata;
Which file extensions, have demo files?
".mpc". Demo files sent in "MPC-no_tags.zip"
Tom wrote:
Bit-rate for APE format doesn't always show correctly (e.g. "-298" "-414", "-814")
Same here, can you provide some demo files?
Happens with some APE CD-images. I tried to make separate track from this image with the same format (using CUE sheet & MAC encoder) and bitrate was fine. Those images are big (266-400 MB) so I uploaded only one in zip-acrhive called "incorrect_APE_bitrate".
Tom wrote:To any of you who experience slower startup than in the Alpha:
Did you actually compare the startup time to the Alpha using the same startup folder? Do you have special shell extensions installed? Does your Explorer lag a bit in certain locations too?
1) Yes, tried to start with the same shortcut. Like alpha was "Resonic", beta was 'Resonic2". Tried alpha, then renamed beta folder to "Resonic". Alpha startup is like 1-1.5 sec, beta - 1.5-2.5 sec; 2) No, nothing special ("Unlocker", "change file extension", "HashCheck", "7-Zip" etc); 3) No.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10897 - Beta Test

Thanks for the files.
Alt wrote:MP4-AAC format in all containers (MP4, M4A, AAC) doesn't play (shows error)
I cannot reproduce this problem. Your test files play on my system properly, even if I delete the bass_aac.dll from plugins/ folder, in which case the Windows (7+) decoder is used.
Musepack format doesn't show any metadata;
Fixed that / implemented full meta support for MPC (APE tags and ID3v1).
Bit-rate for APE format doesn't always show correctly (e.g. "-298" "-414", "-814")
I'm making use of a pre-made library that incorrectly reports the APE audio properties. In the Alpha I seem to have worked around this bug by simply not showing negative numbers, which I'll do here as well as a temporary fix.

Strange@startup speed, I'll observe that. It should in any case be faster.
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10829 - Beta Test

ExtremRaym wrote:[*]Musical Spectrum is blinking
Can you share the audio properties of the files that it's blinking on? (like sample rate, bit depth, channels).
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

Tom
Liqube Audio
Liqube Audio
Posts: 976
Joined: December 12th, 2012, 19:12
First Name: Tom
Primary DAW: Live
Resonic: Pro
Location: Earth (currently)
Contact:

Re: 10897 - Beta Test

resonic-test-141130-10897b

Here's a list of changes/fixes, which includes fixes from the previous build:

Code: Select all

Nov 29—Nov 30   594  After pressing the stop button, pressing the play button does nothing.
Nov 28—Dec 02   567  Browser: Add full expand feature (i.e. *) to folder context menu
Nov 29—Nov 30   577  Can't disable Show level meter.
Nov 29—Nov 30   588  No "play next/prev" track global hotkey?
Nov 29—Nov 30   590  Popup desc for: Rescan, Mute
Nov 29—Nov 30   587  There should also be warning message for 'support the project' button
Nov 29—Nov 30   575  Toggle caption filename: Can hide but not show it again without switching track.
Nov 29—Nov 30   579  Should be able to make Length column narrower.
Nov 29—Nov 30   574  If it's Ext. it doesn't hide the extension from File name column.
Nov 29—Nov 30   576  Avoid scrollbar: The status bar message is the old name.
Nov 29—Nov 30   592  The 'hide mouse inside visualization area' option doesn't work.
Nov 29—Dec 01   583  Musepack format doesn't show any metadata;
Nov 29—Dec 02   584  "Resume playback at startup" doesn't work, track always starts to play from beginning;
Nov 29—Nov 29   573  Roots of Libraries appears empty
Nov 30—Nov 30   609  Disable level meter menu
Dec 01—Dec 01   610  Spectrum style doesn't have a checkmark
Dec 01—Dec 01   613  Reenable DSD/DSF support
Nov 29—Dec 01   582  MP4-AAC format in all containers (MP4, M4A, AAC) doesn't play (shows error);
Nov 29—Dec 02   602  Support for Cyrillic characters in ISO-8859-1 codepage
Nov 29—Dec 02   591  Hitting 'next track' button at the end of the list does nothing. (would be nice if it could loop to the first track when you hit the button manually)
Nov 29—Dec 02   578  Disabling Enable global hotkeys has no effect, also gets unchecked after reopening Preferences.
Dec 02—Dec 02   620  Pause track, reclick file to play, pause button remains highlighted
Nov 29—Nov 30   597  Analyze style "Outline" doesn't change "Musical spectrum" - most likely no bug, but feels a tad inconsistent
[/size]
Also included is partial soundcard switching (see preferences). Baby steps...

Looking forward to your reports!
Join our Discord for chat and talk (not just Resonic related) and beta testing; or the Resonic Users group on FB.

A user interface is like a joke: if you have to explain it, it's not that good.

User avatar
BTGbullseye
Beta Tester
Posts: 137
Joined: March 22nd, 2013, 10:19
Location: a particular place or position.
Contact:

Re: 11006 - Beta Test

No new bugs on my end... All fixes working well.

Thanks for all the hard work Tom!
I don't suffer from insanity... I'm still insane though.

User avatar
wshaper
Beta Tester
Posts: 94
Joined: September 23rd, 2013, 21:06
Primary DAW: Reaper, Live

Re: 10897 - Beta Test

Tom wrote:Also included is partial soundcard switching (see preferences). Baby steps...
Great !

Alt
Beta Tester
Posts: 41
Joined: October 4th, 2014, 13:10

Re: 11006 - Beta Test

Nov 29—Dec 01 582 MP4-AAC format in all containers (MP4, M4A, AAC) doesn't play (shows error);
Unfixed. "Unlocker" shows that bass_aac.dll is in use (just like with previous beta) but still those formats can't be played.
Under XP you can disable audio decoders in "Device Manager - Audio Coders". If it's still such easy under Win7 that could help to make sure.
Nov 29—Dec 02 602 Support for Cyrillic characters in ISO-8859-1 codepage
Also unfixed.
If that could help, I saw that AIMP (both PC and Android) have converter for non-Unicode string. When I selected there 28591 (ISO-8859-1 Latin-1) tags showed wrong, with UTF-8 - didn't show at all, but with 1251 codepage (and UTF-16 I guess) they look properly.

Martin
I know my Resonics, all of them!
Posts: 91
Joined: September 13th, 2014, 19:30
First Name: Martin
Location: On a tree, throwing bananas

Re: 11006 - Beta Test

Alt wrote:Also unfixed.
If that could help, I saw that AIMP (both PC and Android) have converter for non-Unicode string. When I selected there 28591 (ISO-8859-1 Latin-1) tags showed wrong, with UTF-8 - didn't show at all, but with 1251 codepage (and UTF-16 I guess) they look properly.
Right now the system locale is used to do the conversion to Unicode, so if you set that to 'Russian' the tags should appear correctly. This can be turned into an option once the preferences dialog is up and running.
Alt wrote:Under XP you can disable audio decoders in "Device Manager - Audio Coders". If it's still such easy under Win7 that could help to make sure.
You can use autoruns or InstalledCodec to disable individual codecs.

Alt
Beta Tester
Posts: 41
Joined: October 4th, 2014, 13:10

Re: 11006 - Beta Test

Martin wrote:
Alt wrote:Also unfixed.
If that could help, I saw that AIMP (both PC and Android) have converter for non-Unicode string. When I selected there 28591 (ISO-8859-1 Latin-1) tags showed wrong, with UTF-8 - didn't show at all, but with 1251 codepage (and UTF-16 I guess) they look properly.
Right now the system locale is used to do the conversion to Unicode, so if you set that to 'Russian' the tags should appear correctly. This can be turned into an option once the preferences dialog is up and running.
But I have XP with Russian system locale and Regional + Language options (for non-Unicode programs) are also set to Russian.
Still see the same wrong symbols as in Alpha.

Martin
I know my Resonics, all of them!
Posts: 91
Joined: September 13th, 2014, 19:30
First Name: Martin
Location: On a tree, throwing bananas

Re: 11006 - Beta Test

Alt wrote:But I have XP with Russian system locale and Regional + Language options (for non-Unicode programs) are also set to Russian.
Still see the same wrong symbols as in Alpha.
Sorry, you are right. Looks like the latest core library wasn't included for some reason. It'll be fixed in the next build then.
Attachments
Windows XP Professional-2014-12-04-12-58-15.png
Windows XP Professional-2014-12-04-12-58-15.png (12.14 KiB) Viewed 29347 times

Locked